最新消息:欢迎访问天顶选股网!精选选股思路及方法、选股公式,让你选龙头、选牛股!

怎样发现均线粘合的股票?

选股方法 jstd_admin 167浏览

怎样发现均线粘合的股票?很简单,有两种电脑编程自动化筛选方式,一种是编写一个选股公式,另一种是编写一个排序指标,两种方式,任选其一都可以实现。

我给大家举个例子,以排序指标筛选均线粘合的股票为例,公式可以这样写:

MA10:=MA(CLOSE,10);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

X1:=ABS(MA10-MA60)/MA60;

X2:=ABS(MA30-MA60)/MA60;

X3:=ABS(MA10-MA30)/MA30;

NHPX:X1+X2+X3;

当然,也可以将均线的范围放大一些,譬如将均线MA60换成MA120甚至MA250,若两线周期相差太大,周期之间可以增加几条线。以通达信为例,将源码拷贝指标公式编辑器,填入公式名称,点击确认即可。

进入“报价-历史行情.指标排序”,进行排序。

通常需要更换排序指标,选择刚才新建的“均线粘合”排序指标,对沪深A股进行排序

因为是均线粘合排序,所以,应该选择倒序排序,数值越小,说明均线越粘合。

均线粘合

筛选结果,选择一组图示如下:

如果想要筛选均线既粘合,又呈现多头排列形态的目标股,可以在公式中增加多头排列的条件,如下:

MA10:=MA(CLOSE,10);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

X1:=ABS(MA10-MA60)/MA60;

X2:=ABS(MA30-MA60)/MA60;

X3:=ABS(MA10-MA30)/MA30;

TJ:=MA10>=MA30 AND MA30>=MA60;

NHPX:IF(TJ,X1+X2+X3,DRAWNULL);

如有不同意见,欢迎大家留言交流。

转载请注明:天顶选股网 » 怎样发现均线粘合的股票?